LR Disco 3 command shift not working

Land Rover Discovery 1, 2 and 3

Moderator: pretdave

Posts: 1
Joined: 03 Aug 2014 13:28

LR Disco 3 command shift not working

Postby kevin29360 » 13 Jun 2015 17:00

For a while now my command shift has not worked. I have read extensively on the net regarding this subject to find out why and possibly how to fix this. I have noted that some end up solving this problem by replacing a few parts on the gearbox side shifter arm shaft, (this however is not my problem) and where there seems to be someone else coming with light at the end of the tunnel on other possible seems to me they so happy to solve their problem, they never bother to come back and tell us how they solved their problem.
Ever since the command shift on my vehicle stopped working, my 'D' on the gear console stays alight all the time - whether the car is running or not - and shows up the 'D' lighted in red.
My take on this is by now there surely has to be a few people out there with inimate knowledge on this problem and able to supply a concise answer as to what is going on and how to fix it.
Please can someone give me the right advice on this problem, it would be much appreciated and I will be extremely grateful!

Return to “Discovery”

Who is online

Users browsing this forum: No registered users and 2 guests